Satchmo: AssertionError: Signal receivers must accept keyword arguments

Sigh.

Apparently you just can’t install Satchmo as it stands. It needs the latest Django trunk, but doesn’t work with the latest changes. We need to wait for the multi-coloured-swapshop to be integrated.
http://groups.google.com/group/satchmo-users/browse_thread/thread/b871eff0685efd19

So, I just have to wait.
(I’ve tried getting the new branch, but it doesn’t run easily)

Would be nice to have a mention of this on the install docs.

Updated: Sorted. I got revision 8222 of Django out of SVN. I then had to revert the changes I made detailed in my last post.